Partial Microsoft Outage

Incident Report for Utah Valley University

Resolved

The Microsoft services outage has been resolved. Please contact the Service Desk if you encounter any further issues.
Posted Dec 22, 2025 - 16:19 MST

Monitoring

A fix has been applied and Microsoft services should be available for all users. We will continue to monitor this closely.
Posted Dec 22, 2025 - 13:13 MST

Update

The vendor is aware and is actively working to rectify the issue.
Posted Dec 22, 2025 - 11:51 MST

Identified

We have identified a partial Microsoft outage affecting the Service Desk's ability to reset passwords for users as well as other Microsoft account issues. Updates will be provided as we learn more.
Posted Dec 22, 2025 - 11:26 MST
This incident affected: General IT Services.