The AWS outage affecting various UVU services has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 21, 2025 - 15:29 MDT
Monitoring
All services have been validated and should be available to UVU students and employees. We will continue to monitor them closely.
Posted Oct 21, 2025 - 11:22 MDT
Update
Update: All services but Element 451 have been validated as working. Updates will be provided as we learn more.
Posted Oct 21, 2025 - 10:53 MDT
Update
Update: Amazon Web Services reports all systems operational and we are in process of validating our systems. Canvas and Atlassian products (Jira and Confluence) are back online and should be available to all users. Other systems are still awaiting validation.
Posted Oct 20, 2025 - 20:52 MDT
Update
Update: EBSCO and ProQuest research databases are impacted by this issue.
Posted Oct 20, 2025 - 13:19 MDT
Update
Update: Element 451, used for student applications to UVU, and Civitas Advising/Administrative Analytics (Inspire and Illume) are is also affected by this incident.
Posted Oct 20, 2025 - 10:50 MDT
Update
Update: Qualtrics is also affected by this incident.
Posted Oct 20, 2025 - 10:07 MDT
Update
Update: Qualtrics is also affected by this incident.
Posted Oct 20, 2025 - 10:06 MDT
Update
This outage is also affecting Atlassian products, such as Jira and Confluence. Other services could be affected if supported by Amazon Web Services (AWS). Updates will be provided as we learn more.
Posted Oct 20, 2025 - 07:52 MDT
Identified
Instructure has identified an outage affecting Canvas access due to a third-party issue. Canvas will be unavailable until the issue is resolved. Updates will be provided as we learn more. List of affected services: Canvas, Jira/Confluence, Qualtrics, Element 451
Posted Oct 20, 2025 - 07:30 MDT
This incident affected: Teaching, Learning, & Classrooms (Canvas).