Degree Works Outage

Incident Report for Utah Valley University

Resolved

The myUVU Student outage affecting registration has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 01, 2025 - 16:53 MDT

Monitoring

A fix has been applied and MyUVU Student services should be available. We will continue to monitor MyUVU Student services closely.
Posted Apr 01, 2025 - 14:45 MDT

Identified

We have identified an issue affecting student banner services. Updates will be provided as we learn more.
Posted Mar 31, 2025 - 13:58 MDT

Investigating

We are investigating reports of a Degree Works outage. Updates will be provided as we learn more.
Posted Mar 31, 2025 - 13:44 MDT
This incident affected: myUVU Services (myUVU Student Services).