Partial Course Evaluation Outage

Incident Report for Utah Valley University

Resolved

The partial course evaluation outage has been resolved. Please contact the Service Desk if you experience further issues.
Posted Dec 02, 2025 - 08:35 MST

Monitoring

A fix has been applied and course evaluations should be available to be sent to all users. We will continue to monitor this closely.
Posted Dec 01, 2025 - 15:45 MST

Identified

We have identified an outage causing some course evaluations to not be sent. Updates will be provided as we learn more.
Posted Dec 01, 2025 - 10:15 MST
This incident affected: General IT Services.