UFRA Registration Outage

Incident Report for Utah Valley University

Resolved

The registration outage affecting users' ability to register for UFRA winter fire school has been resolved. A registration re-launch will be required. Please see UFRA's website for more information. https://www.uvu.edu/ufra/training/winterfireschool.html
Posted Nov 03, 2025 - 13:38 MST

Investigating

We are investigating reports of a registration outage affecting users' ability to register for UFRA winter fire school. Updates will be provided as we learn more.
Posted Nov 03, 2025 - 09:31 MST
This incident affected: Registration and Planning (Class Registration).