TEST Outage - Testing MyUVU Integration

Incident Report for Utah Valley University

Resolved

This test is complete
Posted Mar 09, 2026 - 09:21 MDT

Identified

This is a test Statuspage post, please disregard.
Posted Mar 09, 2026 - 09:07 MDT
This incident affected: General IT Services.