The Windows Hello service outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Dec 04, 2025 - 08:58 MST
Monitoring
A fix has been applied and Windows Hello login should be available to all users. We will continue to monitor the service closely.
Posted Dec 03, 2025 - 13:49 MST
Identified
We have identified a Windows Hello sign-in outage affecting users' ability to login to Windows using PIN or biometrics, due to a KDC certificate error. Users may log in using their password as a workaround. If you need your UVU Windows password reset, you may request in-person at the Enterprise Service Desk in the LA building hallway, over the phone at 801-863-8000, or online at https://uvu-it.atlassian.net/servicedesk/customer/portal/31/group/117/create/455
Posted Dec 03, 2025 - 08:50 MST
Investigating
We are investigating reports of a Windows Hello PIN login outage affecting some users' ability to log into Windows. Updates will be provided as we learn more.
Posted Dec 03, 2025 - 08:33 MST
This incident affected: Accounts & Access (UVU Accounts).