UVU Lehi Campus Building # 2 Network Outage

Incident Report for Utah Valley University

Resolved

The network outage at UVU Lehi Campus Building # 2 has been resolved. Please contact the Service Desk if you experience further issues.
Posted Dec 22, 2025 - 15:04 MST

Update

We are continuing to monitor for any further issues.
Posted Dec 22, 2025 - 11:11 MST

Monitoring

A fix has been applied and networking should be available to all users at Lehi campus. We will continue to monitor the network closely.
Posted Dec 22, 2025 - 11:10 MST

Investigating

We are investigating reports of a network outage at the UVU Lehi Campus Building # 2. Updates will be provided as we learn more.
Posted Dec 22, 2025 - 09:51 MST
This incident affected: Network & Wireless (Wireless Network, Wired Network).