Partial Microsoft License outage

Incident Report for Utah Valley University

Update

We are still working with the vendor to resolve the issue. Updates will be provided as we learn more.
Posted Nov 07, 2025 - 16:20 MST

Identified

We have identified a Microsoft licensing issue affecting UVU personnel. Some employees are unable to access certain Microsoft products, such as Microsoft365 and Teams. We are working with the vendor to resolve the issue. Updates will be provided as we learn more.
Posted Nov 05, 2025 - 16:16 MST
This incident affects: Email, Calendar, & Collaboration (Employee Email, Teams) and Software, Websites & Apps (Office 365).